OpenRoads Designer CONNECT Edition SDK Help

CantCalculator Class

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public class CantCalculator : IDisposable
Inheritance → CantCalculator
Implements

Properties

Methods

CalculateAllTops  
CalculateRoll  
ComputeCantAtStation(Double, Double)  
ComputeCantAtStation(Double, Double, Double, Double)  
ComputeCantAtStation(Int32, Double, Double, Double, Double)  
CreateProjectedCant  
CreateSimpleCant  
Dispose() Releases all resources used by the CantCalculator
Dispose(Boolean) Releases the unmanaged resources used by the CantCalculator and optionally releases the managed resources
Finalize (Overrides )
GetLength  
TryGetMainlinePoint  
TryGetProjectedStation  

See Also